Django Mysql驱动版本问题 mysqlclient 1.3.13 or newer is required; you have 0.9.3.

2020-03-06 发表在 编程语言 194

错误

...
raise ImproperlyConfigured('mysqlclient 1.3.13 or newer is required; you have %s.' % Database.__version__)
django.core.exceptions.ImproperlyConfigured: mysqlclient 1.3.13 or newer is required; you have 0.9.3.

解决办法

  1. 最直接,最牛X的解决办法,临时修改pymysql的版本

在你初始化mysql的地方 修改为所需要的版本,错误日志中是需要1.3.13改为这个版本即可

import pymysql

pymysql.version_info = (1, 3, 13, "final", 0)
pymysql.install_as_MySQLdb()
  1. 参考以下链接 https://github.com/PyMySQL/mysqlclient-python#install

https://www.cnblogs.com/allen2333/p/11754161.html

作者:贝塔博客
本站使用「署名 4.0 国际」创作共享协议,转载请在文章明显位置注明作者及出处。
评论
登录以后才可以发布评论哦, 点击登录 发布评论
评论列表 0人参与,0条评论
暂时还没有人评论,快来一条神回复吧!